[Frama-c-discuss] Running ocaml on cygwin

Rousset Nicolas Nicolas.Rousset at gemalto.com
Thu Dec 3 15:36:44 CET 2009


First, a remark not related with ocaml, what about installing the latest version of Frama-C (i.e. Beryllium 2)?

Second, let's try a Windows-like path for your OCAMLLIB :
export OCAMLLIB=C:\\Frama-C\\lib

It works for me.

Hope this helps

- Nicolas

________________________________
From: frama-c-discuss-bounces at lists.gforge.inria.fr [mailto:frama-c-discuss-bounces at lists.gforge.inria.fr] On Behalf Of Hollas Boris (CR/AEY1)
Sent: jeudi 3 décembre 2009 15:20
To: Frama-C public discussion
Subject: [Frama-c-discuss] Running ocaml on cygwin

Hi,

I'm having trouble getting ocaml from Frama-C Beryllium 1 work. I removed ocaml.3.10 that I had installed separetely using the uninstaller, cleared registry entries, removed old settings for windows environment variables and added

export OCAMLLIB=/cygdrive/c/Frama-C/lib
export CAML_LD_LIBRARY_PATH=/cygdrive/c/Frama-C/lib/stublibs

to my .bashrc. If I invoke ocaml, I get

~> ocaml
        Objective Caml version 3.11.1

>> Fatal error: cannot open pervasives.cmi
Fatal error: exception Misc.Fatal_error

That missing file is present:

~> l $OCAMLLIB |grep pervasives
pervasives.cmi*
pervasives.cmx*
pervasives.ml*
pervasives.mli*


What else could be wrong?

Regards,
Boris
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.gforge.inria.fr/pipermail/frama-c-discuss/attachments/20091203/722a6f8d/attachment.htm 


More information about the Frama-c-discuss mailing list