[Cado-nfs-discuss] cannot recover after a cadofactor.pl crash

Chris Murphy chrismrph0 at gmail.com
Sun Jun 30 22:38:14 CEST 2013


To follow-up--this was my mistake.  I previously said that I ran the same
command when I tried to recover but that was wrong.  I had changed the wdir
argument to the new backup directory I created.  Once I changed wdir back
to the original path, the script recovered my previous work and completed.

Great software!  Thank you.


On Fri, Jun 28, 2013 at 1:45 PM, Chris Murphy <chrismrph0 at gmail.com> wrote:

> Hi,
>
> I am using cado-nfs 1.1 to factor a c155 number.  The cadofactor.plscript crashed upon starting the linear algebra stage.   I see that this
> issue and a workaround was previously discussed on the list:
> http://lists.gforge.inria.fr/pipermail/cado-nfs-discuss/2012-July/000075.html.
>  I will remove the mpich2 package and try again.
>
> However, now I can't recover using the work files I've already
> accumulated.  I made a backup of the work directory when cadofactor.plcrashed.  I ran the same
> cadofactor.pl command again after I modified my mach_desc file to include
> only localhost and remove the mpi=1 argument.
>
> When prompted, I chose "l" to clean up but continue at the checkpointed
> linear algebra stage.   Unfortunately, the script deleted all my relations
> files and started the polynomial stage again.  After the polynomial stage
> finished, it began sieving again.  Is there any way to recover the work the
> script has already done?  I still have a backup of the work directory.
>
> The "Trying to recover..." operation marks several previous stages as not
> done even though they did complete.
>
> After choosing "l", I see these messages:
>
> Info:polynomial selection not flagged as done, flagging factbase as not
> done
> Info:polynomial selection not flagged as done, flagging sieve as not done
> Info:factor base not flagged as done, flagging freerels as not done
> Info:sieve and purge not flagged as done, flagging dup as not done
> Info:duplicates not flagged as done, flagging purge as not done
> Info:singletons and cliques not flagged as done, flagging merge as not done
> Info:merge not flagged as done, flagging replay as not done
>
> I have 436 files in my work directory, including these:
>
> root at master:/opt/cado-nfs-1.1# ls /fdata/cadorecover/*done
> /fdata/cadorecover/c155.dup_done
> /fdata/cadorecover/c155.merge_done
> /fdata/cadorecover/c155.replay_done
> /fdata/cadorecover/c155.factbase_done
> /fdata/cadorecover/c155.polysel_done
> /fdata/cadorecover/c155.sieve_done
> /fdata/cadorecover/c155.freerels_done
> /fdata/cadorecover/c155.purge_done
>
>
> Thanks.
>
> Chris
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gforge.inria.fr/pipermail/cado-nfs-discuss/attachments/20130630/a54f816b/attachment.html>


More information about the Cado-nfs-discuss mailing list