[Cryptominisat-devel] Warning message when compiling

Martin Maurer meinemailingliste at online.de
Lun 3 Jan 13:49:59 CET 2011


Hello Rob,

can you tell me which version of cryptominisat you have taken ? The latest 
master branch ?
Can you check if you can find "mktemp" or "sem_open" in your version in the 
sources of cryptominisat ?

> Linking CXX executable cryptominisat
> /usr/lib/gcc/x86_64-redhat-linux/4.5.1/../../../../lib64/libpthread.a(libpthread.o):
> In function `sem_open':
> (.text+0x79ee): warning: the use of `mktemp' is dangerous, better use 
> `mkstemp'
> [ 96%] Built target cryptominisat

It is already linking, i am not sure, but it could be that it is a problem 
with Fedora14 itself ?


More information about the Cryptominisat-devel mailing list