[Ecm-discuss] Building GMP-ECM on MacOS Leopard

Paul Leyland paul at leyland.vispa.com
Ven 11 Juil 17:33:04 CEST 2008


On Fri, 2008-07-11 at 15:55, Alexander Kruppa wrote:
> Paul Leyland wrote:
> > I've recently gained access to a MacOS 10.5 (Leopard) system but can't
> > seem to build ecm-6.2.1

> Which directories are the gmp.h and the libgmp.a files in? In my GMP 
> build dir, gmp.h is in the build dir, libgmp.a is in .libs/. If yours is 
> the same, using either only "--with-gmp-build=../gmp-4.2.2" should work, 
> or "--with-gmp-lib=../gmp-4.2.2/.libs  --with-gmp-include=../gmp-4.2.2" 
> (which is exactly what --with-gmp-build does internally).
> 
> Alex

Thanks.  Trying again.  The libgmp.a is indeed in .libs as seen here:

mollie:ecm-6.2.1 paul$ cd ../gmp-4.2.2
mollie:gmp-4.2.2 paul$ find . -name libgmp.a
./.libs/libgmp.a
mollie:gmp-4.2.2 paul$


However

mollie:ecm-6.2.1 paul$ ./configure --with-gmp-build=../gmp-4.2.2
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
...
checking for signal... yes
checking for malloc_usable_size... no
checking gmp.h usability... yes
checking gmp.h presence... yes
checking for gmp.h... yes
checking for recent GMP... yes
checking if gmp.h version and libgmp version are the same... no
configure: error: 'gmp.h' and 'libgmp' have different versions! you have to properly reinstall GMP.
mollie:ecm-6.2.1 paul$


which is exactly the same error I got on my  very first attempt to build
and why I tried separating out the three options.


(BTW, that's a wonderful split infinitive on the last line.   Should be
"... you have to reinstall GMP properly.".)

Paul


-------------- section suivante --------------
Une pièce jointe non texte a été nettoyée...
Nom: non disponible
Type: application/pgp-signature
Taille: 189 octets
Desc: This is a digitally signed message part
Url: http://lists.gforge.inria.fr/pipermail/ecm-discuss/attachments/20080711/4b4db7aa/attachment-0002.pgp 


Plus d'informations sur la liste de diffusion Ecm-discuss