[Ecm-discuss] Building GMP-ECM on MacOS Leopard

Paul Zimmermann Paul.Zimmermann at loria.fr
Jeu 17 Juil 11:35:11 CEST 2008


       Paul,

   mollie:ecm-6.2.1 paul$ ./configure --with-gmp-build=3D../gmp-4.2.2
   checking for a BSD-compatible install... /usr/bin/install -c
   checking whether build environment is sane... yes
   ...
   checking for signal... yes
   checking for malloc_usable_size... no
   checking gmp.h usability... yes
   checking gmp.h presence... yes
   checking for gmp.h... yes
   checking for recent GMP... yes
   checking if gmp.h version and libgmp version are the same... no
   configure: error: 'gmp.h' and 'libgmp' have different versions! you have to=
    properly reinstall GMP.
   mollie:ecm-6.2.1 paul$

   which is exactly the same error I got on my  very first attempt to build
   and why I tried separating out the three options.

did you fix that issue? I just tried on a Core 2 under Fedora 9 and it works
fine. It might be due to the fact that the include and/or lib paths are not
properly set by the configure script, or that the compiler first looks in the
standard places. Can you send me the config.log file?

   (BTW, that's a wonderful split infinitive on the last line.   Should be
   "... you have to reinstall GMP properly.".)

thanks, I have fixed that in the svn version.

Paul Z.




Plus d'informations sur la liste de diffusion Ecm-discuss