[knem-devel] failure with Linux 5.2.7

Brice Goglin Brice.Goglin at inria.fr
Mon Sep 2 15:39:08 CEST 2019


Le 29/08/2019 à 16:48, Dave Love a écrit :
> Brice Goglin <Brice.Goglin at inria.fr> writes:
>
>> Hello
>>
>> It looks like we just have to use cpus_mask instead of cpus_allowed in
>> git master, can you try?
> That does build.  (This seems to have changed with Linux 5.3.)  Do you
> need me to concoct a test for that?
>
> By the way, there are these warnings from the build:
>
>  knem_offload_test.c:64:71: warning: format '%ld' expects argument of type 'long int', but argument 3 has type 'int' [-Wformat=]
>
>  knem_offload_test.c:104:7: warning: 'err' may be used uninitialized in this function [-Wmaybe-uninitialized]


Hello

I just pushed all these fixes to git master. If anybody needs a new
release instead of these kernel patches, please let me know.

Brice




More information about the knem-devel mailing list