[Mpfi-commits] r616 - in trunk/mpfi: . doc

ptheveny at users.gforge.inria.fr ptheveny at users.gforge.inria.fr
Ven 23 Déc 11:55:12 CET 2011


Author: ptheveny
Date: 2011-12-23 11:55:11 +0100 (Fri, 23 Dec 2011)
New Revision: 616

Modified:
   trunk/mpfi/configure.ac
   trunk/mpfi/doc/mpfi.texi
Log:
Raise the required MPFR version up to 2.4.2 (buggy mpfr_coth in ealier versions makes tcoth fail).

Modified: trunk/mpfi/configure.ac
===================================================================
--- trunk/mpfi/configure.ac	2011-12-22 18:25:47 UTC (rev 615)
+++ trunk/mpfi/configure.ac	2011-12-23 10:55:11 UTC (rev 616)
@@ -92,12 +92,12 @@
 AC_MSG_CHECKING(for valid MPFR)
 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
 #include "mpfr.h"
-#if (MPFR_VERSION < MPFR_VERSION_NUM(2,4,0))
-# error "min: MPFR 2.4.0"
+#if (MPFR_VERSION < MPFR_VERSION_NUM(2,4,2))
+# error "min: MPFR 2.4.2"
 #endif
 ]], [[]])],[AC_MSG_RESULT(yes)],[
  AC_MSG_RESULT(no)
- AC_MSG_ERROR([MPFR 2.4.0 min required])
+ AC_MSG_ERROR([MPFR 2.4.2 min required])
 ])
 
 # Checks for header files.

Modified: trunk/mpfi/doc/mpfi.texi
===================================================================
--- trunk/mpfi/doc/mpfi.texi	2011-12-22 18:25:47 UTC (rev 615)
+++ trunk/mpfi/doc/mpfi.texi	2011-12-23 10:55:11 UTC (rev 616)
@@ -242,7 +242,7 @@
 @chapter Installing MPFI
 @cindex Installation
 
-To build MPFI, you first have to install MPFR (version 2.4.0 or above)
+To build MPFI, you first have to install MPFR (version 2.4.2 or above)
 on your computer.
 You need a C compiler, preferably GCC, but any reasonable compiler
 should work.




More information about the Mpfi-commits mailing list