[Paradiseo-help] [paradiseo-Bugs][5607] eoParser does not parser command line arguments

paradiseo-bugs at gforge.inria.fr paradiseo-bugs at gforge.inria.fr
Ven 18 Juil 10:15:14 CEST 2008


Bugs item #5607, was opened at 20/05/2008 17:01
You can respond by visiting: 
http://gforge.inria.fr/tracker/?func=detail&atid=663&aid=5607&group_id=145

>Status: Closed
Priority: 3
Submitted By: Johann Dréo (nojhan)
Assigned to: Nobody (None)
Summary: eoParser does not parser command line arguments 
Resolution: None
Group: 1.1-patch1 and previous
Category: None


Initial Comment:
It seems to be impossible to change the parameters on the command line with the "parser.createParser(...).value()" construction.



As an example, one can try the tutorial in: "paradiseo-moeo/build/tutorial/Lesson1", with a "./Sch1-1.1 -P 2 -G 2", the values used are those hardcoded as default in the parameter creation.



----------------------------------------------------------------------

>Comment By: Arnaud Liefooghe (liefooga)
Date: 18/07/2008 10:15

Message:
It works also with (according to the given example) : "./Sch1-1.1 -P=2 -G=2"

----------------------------------------------------------------------

Comment By: Johann Dréo (nojhan)
Date: 21/05/2008 09:55

Message:
In fact, it is a EO bug, the parser only take into account parameters passed with the syntax "--long-name=value".

----------------------------------------------------------------------

You can respond by visiting: 
http://gforge.inria.fr/tracker/?func=detail&atid=663&aid=5607&group_id=145





Plus d'informations sur la liste de diffusion Paradiseo-help