[Paradiseo-help] Probleme paradise-peo

Sylvain Auliac auliac at ann.jussieu.fr
Mar 8 Juin 13:54:50 CEST 2010


Merci pour votre réponse rapide. Mais je rencontre aussi d'autres problèmes. J'ai réussit à faire tourner les exemples sous ubuntu avec MPICH. Mais comme FreeFem est surtout développé sous mac et la version parrallèle avec OpenMPI, j'ai essayé d'installer paradiseo avec OpenMPI et voici ce que j'obtiens systématiquement:


-e 	# STEP 1  
		--> Installing Paradiseo-EO. Please wait ...
-e 	# STEP 1 OK 

-e 	# STEP 2  
		--> Installing Paradiseo-MO. Please wait ...
-e 	# STEP 2 OK 

-e 	# STEP 3  
		--> Installing Paradiseo-MOEO. Please wait ...
-e 	# STEP 3 OK 

-e 	# STEP 4  
		--> Copy .mpd.conf file in your HOME directory or in /etc if you are root (required for mpich2)  ...
-e 	# STEP 4 OK 

-e 	# STEP 5  
		--> Installing Paradiseo-PEO. Please wait ...

		--> Error when installing Paradiseo-PEO
-e  ### END ###  

  An error has occured : impossible to install Paradiseo-PEO.See /Users/auliac/Desktop/paradiseo-1.2.1/logs/install-paradiseo.20100608132549.log for more details
  Make sure you have the required variables in your environment (ex: by using "echo $PATH" for PATH variable) : 
	-LD_LIBRARY_PATH=<libxml2 install path>/libxml2/lib:$LD_LIBRARY_PATH
	-PATH=<libxml2 install path>/libxml2/bin:<mpich2 install path>/mpich2/bin:$PATH

 => To report any problem or for help, please contact paradiseo-help at lists.gforge.inria.fr and join /Users/auliac/Desktop/paradiseo-1.2.1/logs/install-paradiseo.20100608132549.log

Terminated


Je n'ai effectivement pas la variable LD_LIBRARY_PATH, mais une fois que je sais ça, que faire?






Le 4 juin 2010 à 12:02, paradiseo-help a écrit :

> Bonjour,
> essayez avec un @ devant le fichier de param.
> 
> mpiexec -np 4 ./popEval @param
> 
> Cordialement,
> Paradiseo Team.
> 
> Sylvain Auliac a écrit :
>> Bonjour,  j'essaie de faire fonctionner les exemples de paradiseo avec MPI en vue d'implémenter un algorithme génétique,  hybride... pour le logiciel éléments finis FreeFem++., 
>> La compilation est ok,  mais lorsque je lance un executable,  mettons celui de la Lesson3,  il m'est systématiquement dit que le fichier de paramètre que je passe en argument n'existe pas... Ma ligne de commande correspondante est la suivante : mpiexec -np 4 ./popEval param
>> Que dois-je faire? 
>> Cordialement
>> 
>> Sylvain Auliac
>> Laboratoire Jacques-Louis Lions
>> Université Pierre et Marie Curie
>> mail: auliac at ann.jussieu.fr
>> tel : 01 44 27 71 70
>> 
>> 
>> 
>> 
>> 
>> _______________________________________________
>> Paradiseo-help mailing list
>> Paradiseo-help at lists.gforge.inria.fr
>> http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/paradiseo-help
>>  
> 

Sylvain Auliac
Laboratoire Jacques-Louis Lions
Université Pierre et Marie Curie
mail: auliac at ann.jussieu.fr
tel : 01 44 27 71 70




-------------- section suivante --------------
Une pièce jointe HTML a été nettoyée...
URL: <http://lists.gforge.inria.fr/pipermail/paradiseo-help/attachments/20100608/4ce371dc/attachment.html>


Plus d'informations sur la liste de diffusion Paradiseo-help