[Paradiseo-help] [Paradiseo-users] problem with time display

Johann Dréo johann at dreo.fr
Mer 24 Avr 11:19:09 CEST 2013


On Wed, Apr 10, 2013 at 10:21 AM, Sophie Jacquin <sophie.jacquin at inria.fr>
wrote:
> I'm using paradiseo eo, I built my project using the templates offered in
Lesson 5 of the corresponding course.
> I let my program run for more than two hours but after 3000/ 5000
secondes I have some problem with the time display. In fact at that time,
the time value displayed for the generation x is smaller than that
displayed for the generation x-1 and then all the values of time are
integers.
>
> Do you have an idea of what can create this problem?

This sound a lot like an integer overflow, but it should appear at least
after ~1000 seconds only, using a short unsigned int. For long int, this
scales up to ~50 000 days.

Without having a look at the code, I would advise to check the type used
for storing the number of seconds. Or maybe you're using a timer in
milliseconds?

-- 
Johann
-------------- section suivante --------------
Une pièce jointe HTML a été nettoyée...
URL: <http://lists.gforge.inria.fr/pipermail/paradiseo-help/attachments/20130424/79c815ce/attachment.html>
-------------- section suivante --------------
_______________________________________________
Paradiseo-users mailing list
Paradiseo-users at lists.gforge.inria.fr
http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/paradiseo-users


Plus d'informations sur la liste de diffusion Paradiseo-help