[Pharo-project] Special Objects Array question

Gabriel Hernán Barbuto gbarbuto at gmail.com
Tue Nov 2 11:50:23 CET 2010


Hi

I am looking at MicroSqueak and trying to make it work in a new image.
I run MicroSqueak in a new VM and it works. What is a bit odd is that
MicroSqueak has a different class hierarchy for String. It doesn't
know about ByteString nor WideString and the String class in
MicroSqueak has a different format than the one in recent images.

How is it possible that a MicroSqueak generated image runs on the
recent VMs? The special objects array that MicroSqueak creates is
different. For example, at index 7 MicroSqueak put its own version of
String instead of ByteString. I have tried it on Mac OS X on the
Squeak 4.2.5b1 VM and on Windows on the 4.0.2 VM.

My guess is that it works because MicroSqueak String has the same
structure as ByteString in current images. So the VM does not notice
that it is working with a different object.

Thanks
Gabriel




More information about the Pharo-project mailing list