[Pharo-project] a question about reef naming conventions
diogenes.moreira at gmail.com
Thu Nov 4 00:01:24 CET 2010
I think the third option is clearer than the others.
On Wed, Nov 3, 2010 at 7:52 PM, Esteban Lorenzano <estebanlm at gmail.com>wrote:
> I'm having some doubts about how to call some methods for Reef. To be
> precise, I'm not sure about the naming og the method extensions I'm adding.
> For instance, I have an extension for Object, the method #asView, and some
> others in BlockClosure, #asCallback, asCallbackOn:, etc.
> So... I want to ask which naming convention is better.
> 1) Just let the methods like now?
> 2) adding a prefix, like reView, reCallback, etc.?
> 3) adding a full name prefix, asReefView, asReefCallback, etc.?
> What do you think?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Pharo-project