[Pharo-project] a question about reef naming conventions
stephane.ducasse at inria.fr
Thu Nov 4 09:44:37 CET 2010
how it is right now :)?
On Nov 3, 2010, at 11:52 PM, Esteban Lorenzano wrote:
> I'm having some doubts about how to call some methods for Reef. To be precise, I'm not sure about the naming og the method extensions I'm adding.
> For instance, I have an extension for Object, the method #asView, and some others in BlockClosure, #asCallback, asCallbackOn:, etc.
> So... I want to ask which naming convention is better.
> 1) Just let the methods like now?
> 2) adding a prefix, like reView, reCallback, etc.?
> 3) adding a full name prefix, asReefView, asReefCallback, etc.?
for me asReefView is not the same as reefView
so between reView and reefView I prefer reefView
> What do you think?
More information about the Pharo-project