[Pharo-project] Bugreport?

bb bblochl at arcor.de
Fri Nov 5 22:32:30 CET 2010


Am 05.11.2010 10:31, schrieb bb:
> Am 05.11.2010 10:09, schrieb bb:
>> I tried to proceed as described on
>> http://pharo-project.org/community/issue-tracking and tried to search in
>> the mailing list in the archive. But in trying to access the archive I
>> get the message from Nabble(?):
>>
>> This node has been deleted
>>
>> Here a problem description:
>>
>> I installed Pharo latest version on debian lenny 64 bit and it works
>> properly from start on, but I had/have some problems with Squeak.
>>
>> I installed Pharo (same procedure as above) on red hat 64 bit Kernel
>> 2.6.34.7-61.fc13.x86_64, AMD Turion 64 X2 Mobile Technology TL-56 and it
>> does not work, but Squeak works properly. The message is:
>>
>> [bb at localhost Pharo-1.1-OneClick.app]$ ./pharo.sh
>> libGLU.so.1: cannot open shared object file: No such file or directory
>> could not find module vm-display-X11
>> Abgebrochen (Speicherabzug geschrieben)
>> [bb at localhost Pharo-1.1-OneClick.app]
>>
>> I installed repeatedly and tried to use available VM's from Squeak and
>> also tried some other "tricks", i.e copy all Pharo-files in the same
>> directory ...
>>
>> May be someone else has some experience with Pharon on red hat?
>>
>> Please tell me if it is worth to make a ticket?
>>
>> Regards BB
>>
> Appendix: The libGLU runtime library + development package are
> installed. I will check if there is something on error with that
> packages on fedora/red hat.
> 
> May be someone else has some extended expirence with this issue?
> 
> Tegards BB
> 

Thanks for the correct link for bug-reporting!

Thanks for many helping contributions and help to that topic!

At least I found a striking explanation and I think the developers of
Pharo might take care of:

The libGLU-files on fedora13 are not in the directory /usr/lib but in
/usr/lib64. I cross-checked debian lenny and found that libs in
/usr/lib. (lenny does have a directory usr/lib64 as well.)

I had to deal with such differences of different Linux brands and while
moving to 64 bit very often in the past.

I am not a Pharo-developer, but I recommend to check the pathes set and
eventually extend the settings with the 64-bit alternatives.

An alternative might be a hard link?

~$ ln /usr/lib64/libGLU.so.1 /usr/lib/libGLU.so.1

But now I ave another error message:

~ Pharo-1.1-OneClick.app]$ ./pharo.sh
libGLU.so.1: wrong ELF class: ELFCLASS64
could not find module vm-display-X11
Abgebrochen (Speicherabzug geschrieben)

I am not allmighty and more or less just a hobbyist with just an
underdeveloped CS knowledge, but I think that there is a trial to link a
32 bit Pharo with an object-file (libGLU.so.1) which was compiled for 64
bit? (May be that debian still delivers a 32 bit object file, so it works??)

One might try to recompile with the '-m64' flag of gcc. May be a
compilerrun with correct autoconf (configure) scripts, set to CC="gcc
-m64" (or CC="gcc -m32") might help?

So I would say, the problem is fixed but not solved.

Regards BB




More information about the Pharo-project mailing list