[Pharo-project] Problem with de Traits

Mariano Martinez Peck marianopeck at gmail.com
Wed Nov 17 01:45:41 CET 2010


On Fri, Nov 12, 2010 at 10:56 AM, Diogenes Moreira <
diogenes.moreira at gmail.com> wrote:

> well,, that was extrange..
> I'm add this line to my method..
>
>
> classesIncluded
> | includes |
> includes := OrderedCollection new.
> * TSSerosDB users do:[:e | Transcript show: e printString ;cr].*
>
> TSSerosDB users do:[ :aClass | self processClass: aClass into: includes ].
> ^ includes.
>
> And that start work well.. I dont have any Idea what happeng here... but
> work..
>
> Thank for you answer..
>
> BTW im using Pharo 1.2 one click env,
>

There is no Pharo 1.2 one click  ;)




> in ubuntu linux.
>
> On Fri, Nov 12, 2010 at 4:54 AM, Stéphane Ducasse <
> stephane.ducasse at inria.fr> wrote:
> > TPureBehavior users do: [:e | Transcript show: e printString ;cr]
> >
> >        TraitBehavior
> >        Behavior
> >
> > in 1.1 and 1.2
> >
> > so may be you should mentioned your configuration and also get an example
> that we can run.
> > It would be more efficient to help you, isn't?
> >
> > Stef
> >
> > On Nov 12, 2010, at 2:07 AM, Diogenes Moreira wrote:
> >
> >> Hi Folks..
> >>
> >> I have the following method
> >>
> >>
> >> classesIncluded
> >>       | includes |
> >>       includes := OrderedCollection new.
> >>       TSSerosDB users do:[ :aClass | self processClass: aClass into:
> includes ].
> >>       ^ includes.
> >>
> >>
> >> TSSerosDB is a Trait..
> >>
> >> Well when I run the process, I get a MNU.. reciver of users is nil
> >>
> >> But If  I inspect   "TSSerosDB users", i get a Identity Set...
> >>
> >> What's wrong.. why the debugger get something different to another
> process
> >>
> >> Thanks in advance..
> >>
> >
> >
> >
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gforge.inria.fr/pipermail/pharo-project/attachments/20101116/73bb7732/attachment.htm>


More information about the Pharo-project mailing list