[Pharo-project] Is FFI (installation) broken?

Mariano Martinez Peck marianopeck at gmail.com
Sat Nov 27 17:11:09 CET 2010


Hi John. That link is outdated :(
We do not use ScriptLoader anymore to install packages. The recommended way
to install external packages in Pharo is now using Metacello.

To install FFI in Pharo, evaluate:

Gofer new
    squeaksource: 'MetacelloRepository';
    package: 'ConfigurationOfFFI';
    load.

((Smalltalk at: #ConfigurationOfFFI) project version: '1.3') load.


For more information about Metacello:

http://code.google.com/p/metacello/


On Sat, Nov 27, 2010 at 4:18 PM, John Cromartie <jcromartie at gmail.com>wrote:

> I followed the advice here:
> http://code.google.com/p/pharo/wiki/CodeSnippets
>
> I tried to do:
>
>  ScriptLoader loadFFI.
>
> but the method loadFFI does not exist.
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gforge.inria.fr/pipermail/pharo-project/attachments/20101127/76405bd0/attachment.htm>


More information about the Pharo-project mailing list