[Pharo-project] [Vm-dev] FW: Debugging Cog crash

David T. Lewis lewis at mail.msen.com
Fri Apr 8 16:32:32 CEST 2011


Yes, the libuuid.so bug would be a likely suspect. If the UUIDPlugin was
built as an external library, just delete it and you will probably be
good to go.

If you need further info, look here:
http://bugs.squeak.org/view.php?id=7358

Dave

On Fri, Apr 08, 2011 at 07:58:39AM -0400, Schwab,Wilhelm K wrote:
> 
> Gratuitous default recipient...
> 
> If there is a verbose dump option or other diagnostic efforts that will help, I will do my best to run them and report the results.  I am fairly certain the vm is 'Croquet Closure Cog VM [CoInterpreter VMMaker-oscog.54]' (can verify later today), but this happened with an earlier Cog one-click too.  There is something about the machine (UUID again?) that is different.  I do not have root access to it, but I can get to a terminal.  Ubuntu 10.10.
> 
> 
> ________________________________________
> From: Schwab,Wilhelm K
> Sent: Friday, April 08, 2011 7:44 AM
> To: Mariano Martinez Peck
> Subject: RE: [Pharo-project] Debugging Cog crash
> 
> Mariano,
> 
> I first identified this problem/opportunity a while ago.  At the time, there was no log - the vm just died.  I can sniff around again as there might be one this time.  My question at the time was whether there was something that I could enable to perhaps get more info.
> 
> The output from the vm is, and I quote<g> "Segmentation fault".  There is no other output.  Perhaps it does not get far enough to have a call stack??
> 
> Bill
> 
> 
> 
> ________________________________________
> From: Mariano Martinez Peck [marianopeck at gmail.com]
> Sent: Friday, April 08, 2011 3:42 AM
> To: Squeak Development Discussion Virtual Machine; Pharo Development
> Cc: Schwab,Wilhelm K
> Subject: Re: [Pharo-project] Debugging Cog crash
> 
> also...shouldn't be a crash/dump file somewhere?
> 
> can you write the output of the console where you invoke the VM into a file ?   (using > to redirect)
> 
> Cheers
> 
> Mariano
> 
> On Thu, Apr 7, 2011 at 11:10 PM, Schwab,Wilhelm K <bschwab at anest.ufl.edu<mailto:bschwab at anest.ufl.edu>> wrote:
> Hello all,
> 
> I have an account on an Ubuntu terminal server (at least I think that's what it would be called) running 10.10.  The Cog one-click image crashes with "Segmentation fault" (if run from a terminal); the legacy VM seems to run the image nicely on the box.  Any ideas?  I will happily collect any facts that will be of help, but I need some
> direction.
> 
> Bill
> 
> 
> 
> 
> 
> 
> --
> Mariano
> http://marianopeck.wordpress.com



More information about the Pharo-project mailing list