[Pharo-project] [Vm-dev] Debugging Cog crash

Schwab,Wilhelm K bschwab at anest.ufl.edu
Sat Apr 9 23:13:43 CEST 2011


Levente,

Yes, I did follow your instructions, and got the same error message reported in the post I cited.  The solution only solution I have found to that problem is the get the image up and running and THEN attach gdb to it.  I can't do that, because the vm dies way too early for that to work.  So, I would need to attach, or find another solution to the problem.

Bill




Levente wrote:

Did you follow my instructions? If so, then you don't have to attach at 
all, because you started the VM process from gdb, so gdb is attached to 
the process already. Just do exactly what I wrote and you'll have what you 
need.

If you need more help, then try the following links (first hits for 
http://www.google.com/search?ie=UTF-8&q=how+to+use+gdb btw):
- http://www.unknownroad.com/rtfm/gdbtut/gdbuse.html
- http://www.cs.cmu.edu/~gilpin/tutorial/


Levente


________________________________________
From: pharo-project-bounces at lists.gforge.inria.fr [pharo-project-bounces at lists.gforge.inria.fr] On Behalf Of Schwab,Wilhelm K [bschwab at anest.ufl.edu]
Sent: Saturday, April 09, 2011 8:19 AM
To: Pharo-project at lists.gforge.inria.fr; Squeak Virtual Machine Development Discussion
Subject: Re: [Pharo-project] [Vm-dev] Debugging Cog crash

Is there a debug version of Cog that I can run on the box?  I have casually avoided learning how to build Cog in part because that means I can't hack the FFI plugin, which forces me to play by the rules on library paths/ldconfig, etc.  It also means that I don't have a build environment ready to go, so I can't readily add syslog() calls to bracket where it quits.  gdb isn't helping as described below.

If there is something you want me to try, let me know.  We have a reproducible Cog crash.


________________________________________
From: pharo-project-bounces at lists.gforge.inria.fr [pharo-project-bounces at lists.gforge.inria.fr] On Behalf Of Schwab,Wilhelm K [bschwab at anest.ufl.edu]
Sent: Friday, April 08, 2011 6:03 PM
To: Pharo-project at lists.gforge.inria.fr; Squeak Virtual Machine Development Discussion
Subject: Re: [Pharo-project] [Vm-dev] FW:  Debugging Cog crash

Levente,

I follow on why my shell script did not work.  Your instructions got me going, but we still don't have an answer.  The vm is running, but I cannot attach:

    http://lists.squeakfoundation.org/pipermail/vm-dev/2008-March/001840.html



More information about the Pharo-project mailing list