[Pharo-project] Improving Pharo's Exception Hierarchy

Miguel Cobá miguel.coba at gmail.com
Wed Apr 13 18:55:48 CEST 2011


El mié, 13-04-2011 a las 14:52 +0200, Camillo Bruni escribió:

> And as Mariano pointed out, there should be a convention on the
> naming: I am still not sure about suffixing the exception classes with
> "Exception", but I guess this is a good thing to do. Though I must say
> that I omitted it so far ;) and just put the verb there, but that can
> be easily changed.

I would say no to suffixes. Analogous to announcements, they shouldn't
have the suffix. The name should be descriptive enough and intention
revealing that the suffix isn't needed in most cases. For example, I
think that

DividedByZero 

is better than

DividedByZeroException

and no information is lost with the sorter name. Instead, DivideByZero
isn't clear enough to indicate that is a event that happened.

What do you think?

-- 
Miguel Cobá
http://twitter.com/MiguelCobaMtz
http://miguel.leugim.com.mx






More information about the Pharo-project mailing list