[Pharo-project] Improving Pharo's Exception Hierarchy

Camillo Bruni camillo.bruni at inria.fr
Wed Apr 13 19:05:22 CEST 2011


On 2011-04-13, at 18:55, Miguel Cobá wrote:

> El mié, 13-04-2011 a las 14:52 +0200, Camillo Bruni escribió:
> 
>> And as Mariano pointed out, there should be a convention on the
>> naming: I am still not sure about suffixing the exception classes with
>> "Exception", but I guess this is a good thing to do. Though I must say
>> that I omitted it so far ;) and just put the verb there, but that can
>> be easily changed.
> 
> I would say no to suffixes. Analogous to announcements, they shouldn't
> have the suffix. The name should be descriptive enough and intention
> revealing that the suffix isn't needed in most cases. For example, I
> think that
> 
> DividedByZero 
> 
> is better than
> 
> DividedByZeroException
> 
> and no information is lost with the sorter name. Instead, DivideByZero
> isn't clear enough to indicate that is a event that happened.
> 
> What do you think?

If this has been applied in the same sense before and its not a big deal I would prefer no suffixes as well.

camillo
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gforge.inria.fr/pipermail/pharo-project/attachments/20110413/df8c0a98/attachment.htm>


More information about the Pharo-project mailing list