[Pharo-project] OSProcess and CommandShell

sourav roy sourav_pharo at in.com
Mon Apr 18 18:04:12 CEST 2011


Hii tried the way to suggested but i am still getting the same error. My pharo version is 1.1.1. do you think this may be the reason.i am attaching a snapshot.ThanksSourav Original message From:"Mariano Martinez Peck"< marianopeck at gmail.com >Date: 18 Apr 11 02:38:45Subject: Re: [Pharoproject] OSProcess and CommandShellTo: Pharoproject at lists.gforge.inria.fr;Cc: miguel.coba at gmail.comCan you try evaluating ConfigurationOfMetacello project latestVersion load.And then Gofer new squeaksource: 'MetacelloRepository'; package: 'ConfigurationOfOSProcess'; load.((Smalltalk at: #ConfigurationOfOSProcess) project version: #stable) load. if it works, I explain you what it was. On Sun, Apr 17, 2011 at 8:18 PM, sourav roywrote: hi....while loading i m getting some error. Please advice...c the attachmentThanks Sourav Original message From:"Miguel Cobá"< miguel.coba at gmail.com >Date: 14 Apr 11 01:59:21 Subject: Re: [Pharoproject] OSProcess and CommandShellTo: Pharoproject at lists.gforge.inria.fr
 OSProcess is supported and all tests are green in Pharo 1.1 and Pharo 1.2.The stable version for Pharo 1.2 is the 4.4.0 but you can also load andrun 4.3.11 and 4.3.12 (although if you don't disable deprecationswarnings a lot of pop ups will show). 4.4.0 doesn't have problems with deprecated methods.To load:Gofer new squeaksource: 'MetacelloRepository'; package: 'ConfigurationOfOSProcess'; load.((Smalltalk at: #ConfigurationOfOSProcess) project version: #stable) load.CommandShell hasn't a configuration so you'll have to load it from themonticello repository following the documentation of it somewhere in thewiki.CheersEl mié, 13042011 a las 15:23 0300, Casimiro de Almeida Barreto escribió:> I'd like to know the state of:> > OSProcess> and> CommandShell> > under pharo.> > There's a ConfigurationOfOSProcess but there's no > ConfigurationOfCommandShell.> > What's working and what's not working?> > Best regards> > CdAB>  Miguel Cobáhttp://twitter.com/MiguelCobaMtz http://miguel
 .leugim.com.mxGet Yourself a cool, short @in.com Email ID now!  Marianohttp://marianopeck.wordpress.com Get Yourself a cool, short @in.com Email ID now!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gforge.inria.fr/pipermail/pharo-project/attachments/20110418/7414bfaa/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: loaderror.jpg
Type: image/jpeg
Size: 146871 bytes
Desc: not available
URL: <http://lists.gforge.inria.fr/pipermail/pharo-project/attachments/20110418/7414bfaa/attachment.jpg>


More information about the Pharo-project mailing list