[Pharo-project] SqueakSource 3

Tobias Pape Das.Linux at gmx.de
Wed Apr 20 17:01:54 CEST 2011


Am 2011-04-20 um 16:32 schrieb Dale Henrichs:

> 
> On Apr 20, 2011, at 6:27 AM, Tobias Pape wrote:
> 
>> 
>> To Dale or whoever is capable of this:
>> 
>> 	How shall I specify 'I want a working Seaside of version X'
>> 	in my metacello Config?
>> 
>> 	Aparently, doing
>> 
>> 	spec 
>> 	  package: 'SqueakSource-Core' with: [ 
>> 	    spec requires: #( "…" 'Seaside Extras' "…" )];
>> 	  project: 'Seaside Extras' with: [
>> 	    spec
>> 	      className: 'ConfigurationOfSeaside30';
>> 	      loads: #('Seaside-Email' 'RSS-Core');
>> 	      file: 'ConfigurationOfSeaside30';
>> 	      versionString: '3.0.4';
>> 	      repository: 'http://www.squeaksource.com/MetacelloRepository'];
>> 
>> 	does not suffice.
> 
> 
> When you "does not suffice", what is it that is not sufficient and what is your goal?

When I use the config as above,
And I just use the Config to Install SqueakSource into
a seaside-less image, I get a ‘stub’ seaside with no adaptors,
not ready to server…

So Long,
	-Tobias


More information about the Pharo-project mailing list