[Pharo-project] About FileSystem

Dale Henrichs dhenrich at vmware.com
Thu Feb 3 22:18:52 CET 2011


On Feb 3, 2011, at 1:08 PM, Stéphane Ducasse wrote:

> I tried to publish a new configurationOfFilesystem
> but after 15 min I stopped because I could not make it load.
> For me there is something wrong with the interface of metacello because I can never remember it 
> version: '1.0.2' did not load it while it defined as version: #'1.0.2'
> and of course I tried string and symobols....

Stef,

I recommend that you try to use the validator:

  (MetacelloToolBox validateConfiguration: ConfigurationOfFilesystem)
	inspect

The validator should complain about using #'1.0.2' or '1.0.2' incorrectly. If the issue printString isn't enough you should be able to get more info from the #reasonCode:

  MetacelloToolBox descriptionForValidationReasonCode: <reasonCode from validation issue>

If the validator doesn't provide a good enough explanation, I'm interested in improving it. 

If you run into a problem when you reconstruct the configuration and the validator doesn't give you good information, then please feel free to ship me a copy of the configuration so I can be the human validator - which in turn will spur me on to improve the validator:)

I extend this invitation to anyone having trouble with Metacello.

Dale



More information about the Pharo-project mailing list