[Pharo-project] Hudson build for Seaside too?

Sven Van Caekenberghe sven at beta9.be
Fri Feb 4 00:16:53 CET 2011


Hi Torsten,

Thanks for the quick reply.

On 03 Feb 2011, at 22:02, Torsten Bergmann wrote:

> Hi Sven,
> 
> works for me without a problem. I work in latest pharo-dev 1.2 with
> Seaside 3.0.3 loaded. Can run JqueryWidgetBox and MetaSource
> for example without any problem, just bootstrapped today using
> the configs. There are some red tests due to the fact that
> Seaside uses Preferences in some packages and these are thrown
> out in Pharo 1.2.
> 
> Maybe your image is outdated. Did you try one of the prebuilt
> clean pharo 1.2 images from the hudson server  
>       http://ci.pharo-project.org ?
> 
> Try the one from the latest working build from today (see [1]) 
> and download the image (direct url to the ZIP is [2]).

I did take a fresh image.

> Make sure you start in a new directory (or at least rename
> the package-cache folder). Then run the following expressions:

I did not, why is this necessary (loading all these packages is slow enough already) ?

But that seems the only variable, a specific, named package should always be the same no matter what, right ?

>  DEVImageWorkspaces openExternalProjectWorkspace
> 
> In this workspace run the first script
> 
>    Gofer new
> 		squeaksource: 'MetacelloRepository';
> 		package: 'ConfigurationOfSeaside30';
> 	load.
> 	
> 	((Smalltalk at: #ConfigurationOfSeaside30) project latestVersion) load.	

That is the expression that I tried.

> Tell me if this works for you.

I will try again tomorrow, I will let you know.
It is good to know that it works for you.

Sven





More information about the Pharo-project mailing list