[Pharo-project] "Error: No content to install" starting Pharo 1.2 on Windows - bug or feature?

Joachim Geidel joachim.geidel at onlinehome.de
Sat Feb 5 10:43:34 CET 2011


I ran into an error when starting a Pharo 1.2RC2 (build 119) image on Windows
XP. What I did was:
- on Mac OS X, create a new directory "Pharo-1.2-build119"
- copy the image, changes file, and sources file from the one-click app to
this directory
- started the image, saved it as "jniport20.image", and worked a bit with it
- started Windows XP under Parallels, opened an explorer on
Pharo-1.2-build119
- placed a link to squeak.exe in the directory which points to
     Y:\Entwicklung\Pharo\PharoOneClick1.2.app\Contents\Windows\Squeak.exe
  and has
     Y:\Entwicklung\Pharo\Pharo-1.2-build119
  as the working directory
- dropped jniport20.image on the link.

The image starts okay, but immediately opens an error notifier with an
"Error: No content to install" in CodeLoader>>installSourceFile:. The
CodeLoader's sourceFiles instvar hold an Array(a HTTPDownloadRequest), where
the HTTPDownloadRequest has 
     'Y:\Entwicklung\Pharo\Pharo-1.2-build119\PharoOneClick1.2.image' 
as its URL.

I have seen issue 3595 "problem starting up with a script on windows" which
has been closed, apparently because it was not considered a bug. However,
that seems to be something different involving startup scripts.

What am I doing wrong? Or is it a bug?

Regards,
Joachim Geidel

-- 
View this message in context: http://forum.world.st/Error-No-content-to-install-starting-Pharo-1-2-on-Windows-bug-or-feature-tp3261641p3261641.html
Sent from the Pharo Smalltalk mailing list archive at Nabble.com.




More information about the Pharo-project mailing list