[Pharo-project] [ANN] Alien on Pharo 1.2

Luc Fabresse luc.fabresse at gmail.com
Sat Feb 5 11:29:01 CET 2011


Hi Serge,

 I guess that you use an old version of 1.1.1.
 It requires the updated version of
SmalltalkImage>>recreateSpecialObjectsArray (array size of 55).

 For older version (array size of 50 such as Pharo 1.0 or Squeak 4.1 also I
guess) you should load Alien-Core-LucFabresse.66 and not the latest core
Alien-Core-IgorStasenko.68.

Steps for a running Alien in 1.1.1 (resp 1.2) with MacVM 4.2.5b1:

 1) download a fresh 1.1.1 (Latest update: #11418)
 2) Load:  ConfigurationOfAlien-LucFabresse.34
 3) (ConfigurationOfAlien project version: 'Pharo 1.1') load: {'All'.
'MacOSX'}
 4) 40 run, 40 passes, 0 expected failures, 0 failures, 0 errors, 0
unexpected passes

 be happy ;-)

#Luc


2011/2/5 Serge Stinckwich <serge.stinckwich at gmail.com>

> On Sun, Jan 30, 2011 at 7:05 PM, Luc Fabresse <luc.fabresse at gmail.com>
> wrote:
> > Hi all,
> > I just committed new versions of Alien on squeaksource to make it run on
> 1.2
> > I also modified the ConfigurationOfAlien to easily load it:
> > (ConfigurationOfAlien project version: 'Pharo 1.1') load
>
> I try to load Alien in a new Pharo 1.1.1 one click image on my MBP and
> i've got the following message:
>
> "This version of ALIEN assumes a size of 55 in the array of special
> objects, if loaded would cause the image to crash!. Please contact the
> Alien package developers"
>
> --
> Serge Stinckwich
> UMI UMMISCO 209 (IRD/UPMC), Hanoi, Vietnam
> Every DSL ends up being Smalltalk
> http://doesnotunderstand.org/
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gforge.inria.fr/pipermail/pharo-project/attachments/20110205/859c688f/attachment.htm>


More information about the Pharo-project mailing list