[Pharo-project] about FS: a roadmap

Stéphane Ducasse stephane.ducasse at inria.fr
Wed Feb 9 19:07:27 CET 2011


I was bored in the train so ... 

I did that and now I will do it regularly.


- I added trace to gather the exact type of arguments.... and 
- moved FSLocator out of core and in resolver.
- added comments to FSFileSystem>>fileExist: and friends.
- changed category name error handling -> error raising
- better argument name for createDirectory
- added comment to createDirectory
- added comment to copy and friends
- added comment to ensureDirectory:
- added comment to isDirectory:
- added comment to isFile:
- added comment to open: aStringOrPath writable: aBoolean 
- added comment to readStreamOn: aStringOrPath

Next step
- should probably rename FileExists as FileAlreadyExistsError

Stef




More information about the Pharo-project mailing list