[Pharo-project] about FS: a roadmap
damien.pollet at gmail.com
Sun Feb 20 04:17:12 CET 2011
On Fri, Feb 11, 2011 at 19:45, Stéphane Ducasse
<stephane.ducasse at inria.fr> wrote:
> - renamed workingDirectory into workingDirectoryPath
> - added FSDiskFileSystem class>>workingDirectory
> - renamed working into workingDirectory.
> - deprecate working
I think isWorkingDirectory should be renamed to isEmpty. It's only
used in this meaning anyway.
A real isWorkingDirectory should resolve paths and check equality or
something like that, so that it works even if you give it a fully
expanded path rather than just ./
type less, do more [ | ] http://people.untyped.org/damien.pollet
More information about the Pharo-project