[Pharo-project] about FS: a roadmap
stephane.ducasse at inria.fr
Sun Feb 20 09:01:27 CET 2011
> <stephane.ducasse at inria.fr> wrote:
>> - renamed workingDirectory into workingDirectoryPath
>> - added FSDiskFileSystem class>>workingDirectory
>> - renamed working into workingDirectory.
>> - deprecate working
> I think isWorkingDirectory should be renamed to isEmpty. It's only
> used in this meaning anyway.
> A real isWorkingDirectory should resolve paths and check equality or
> something like that, so that it works even if you give it a fully
> expanded path rather than just ./
commit and merge :)
Damien better commit into squeaksource/fs dans pharotaksForces.
Ok now heading towards the month saint michel and before the breakfast :)
> Damien Pollet
> type less, do more [ | ] http://people.untyped.org/damien.pollet
More information about the Pharo-project