[Pharo-project] FileSystem. Possible FSReference rename
maxleske at gmail.com
Thu Feb 24 21:37:12 CET 2011
Maybe I'm just retelling a story but there is already a class called FSLocator. If FSReference would be renamed to FSLocation I think FSLocator would have to be renamed too.
On 23.02.2011, at 00:28, Stéphane Ducasse wrote:
> On Feb 21, 2011, at 2:54 PM, Denis Kudriashov wrote:
>> I hear many people does not like name FSReference in FileSystem package. Me too. Its not clear to me. But it is main object for end user.
>> Maybe we can rename it to FSLocation?
> FSReference = FSSystem + FSPath
> So may be it could be renamed FSLocation.
>> I frequently name variables that point to some file/dir like imagesLocation, settingsLocation and others. Therefore it is natural to me have FSLocation instead FSReference.
>> What do you think?
More information about the Pharo-project