[Pharo-project] Pharo 1.2 broken on Hudson due to XMLSupport changes

Dale Henrichs dhenrich at vmware.com
Sat Feb 26 01:43:40 CET 2011


I've downloaded a Pharo1.2 image from Hudson to see what's happening and 
I notice that there are a number of validation issues with the 
ConfigurationOfPharo ... so I think that the XMLSupport issues have been 
addressed ... this build is yello and the earlier build was red ...

Is that right? Or are there other things that I don't know about?

Dale
On 02/25/2011 04:11 AM, Torsten Bergmann wrote:
> Still I do not understand:
>
> Evaluate this in an updated Pharo core 1.2:
>
> ------------------------------------------------------------------------
>    Gofer new
>      squeaksource: 'MetacelloRepository';
>      package: 'ConfigurationOfXMLSupport';
>      load.
> 	
>    (Smalltalk at: #ConfigurationOfXMLSupport) project latestVersion
> ------------------------------------------------------------------------
>
> returns  1.1.8 [ConfigurationOfXMLSupport]
>
> This is now broken by Otto. OK, he broke it, he has to repair it;)
>
> But independent from that, the method in:
>
>   ConfigurationOfPharo>>version12beta2:
>
> includes the following:
>
>     project: 'XMLSupport' with: '1.1.6'.
>
> So I would have expected that for Pharo "1.2-beta2" the 1.1.6 (and not the
> 1.1.8) of XMLSupport gets loaded and Hudson should have been green.
>
> Why does Metacello load the 1.1.8 when a previous project version (1.1.6)
> is referenced?
>
> Dale, any comments?





More information about the Pharo-project mailing list