[Pharo-project] System time

Jimmie Houchin jlhouchin at gmail.com
Mon May 2 07:00:54 CEST 2011


I downloaded the latest Pharo 1.3 and Cog vm to my Vista server.

I opened up a workspace and did the following at as precisely as my hand 
eye coordination allow at the top of the minute shown.

The first time at the bottom shows exactly identical time with the OS clock.
The second time above it, show a 5 second gain in time in a little over 
24 hours.

I am going to let this image keep going and see how it continues.

DateAndTime now.
2011-05-01T23:45:05-05:00   lost 5 seconds since the below
2011-04-30T20:16:00-05:00  opened Pharo and checked time.

For me, this is now verified on 2 Windows Vista computers. One a laptop, 
and the other a Desktop machine I use as a server. Both are reasonably 
current Dells. The laptop with a duo-core processor and the desktop a 
quad-core processor.

I have not done any attempts on any other OS.

Thanks.

Jimmie



On 4/30/2011 12:03 PM, Jimmie Houchin wrote:
> I am developing a time sensitive application. I poll a server every 
> minute for new data. The data is time sensitive and the sooner I can 
> get the data to the release of the data the better.
>
> I have noticed that Pharo's system time drifts away from the OS system 
> time. I would really like the Pharo system time to be the correct time.
>
> I have not been able to find where in Pharo I can call to update the 
> System clock to the correct time.
>
> Any help greatly appreciated.
>
> Jimmie




More information about the Pharo-project mailing list