[Pharo-project] PharoCore 1.3 built stalled

Stéphane Ducasse stephane.ducasse at inria.fr
Tue May 3 00:49:52 CEST 2011


it is my fault but I have no idea how to solve it.
A package was loading over an already existing one and you get a pop up.

Stef

On May 2, 2011, at 11:39 PM, Igor Stasenko wrote:

> On 2 May 2011 23:26, Igor Stasenko <siguctua at gmail.com> wrote:
>> On 2 May 2011 23:13, laurent laffont <laurent.laffont at gmail.com> wrote:
>>> Last built started more than 1 day ago and not finished ....
>>> Laurent.
>> 
>> This is not good. I killed the jobs. Lets see if it will repeat again.
>> 
> 
> Okay the problem is that there is a warning and it is handled by
> MorphicUIManager,
> instead of NonInteractiveUIManager which just forcing it to always
> proceed, while morphic one
> expects user to press proceed or abandon.
> 
> So, the problem is with an update of
>                progressTitle:  'Loading 13179-Pha-PlentyOfCleans...'
> 
> 
> But i don't undestand why it not switched to NonInteractiveUIManager
> at image startup.
> Aha.. i guess i know why.
> Is its not because command line stuff that are triggered at image
> startup, which tries to evaluate some code
> before full startup procedure completes?
> 
> A command line , i think should be changed to start loading external
> code only after
> everything else is started (including UI manager).
> Otherwise we will have problems like that.
> 
>> --
>> Best regards,
>> Igor Stasenko AKA sig.
>> 
> 
> 
> 
> -- 
> Best regards,
> Igor Stasenko AKA sig.
> 




More information about the Pharo-project mailing list