[Pharo-project] If sources file is not present, something bad happens

Mariano Martinez Peck marianopeck at gmail.com
Mon May 9 16:56:48 CEST 2011


http://code.google.com/p/pharo/issues/detail?id=4173

On Sun, May 8, 2011 at 10:04 PM, Stéphane Ducasse <stephane.ducasse at inria.fr
> wrote:

> We will check that.
> I know that we should condense the changes to see if we can make it.
> I know that there was a problem the last time I tried.
>
> stef
> On May 8, 2011, at 9:50 PM, Mariano Martinez Peck wrote:
>
> > Hi guys. In pharo 1.1, 1.2 (in fact, always) one could decide not to use
> the .sources file and instead decompile. At startup the image raises a popup
> saying "ehhhh the .sources couludnt be found" and then after, when you
> browse a method you see the decompiled code.
> >
> > Now, in Pharo 1.3 I REMOVE all possible .sources and the image doesn't
> say anything at startup. No popup. If I print SourceFiles I get -> an
> ExpandedSourceFileArray(nil MultiByteFileStream:
> '/Users/mariano/Pharo/imagenes/PharoCore-1.2/PharoCore-1.2.changes')
>  So...the sources is not there. Two problems:
> >
> > 1) the first one is that the popup doesn't raise.
> >
> > 2) I cannot browse methods because a popup raises saying there was a
> probelm with the sources file: "There may be a problem with your sources
> file!".
> >
> > I attach screenshot.
> >
> > So...what could be happening?   I will try to debug it... If someone can
> confirm please I open an ticket.
> >
> > --
> > Mariano
> > http://marianopeck.wordpress.com
> >
> > <Screen shot 2011-05-08 at 9.49.04 PM.png>
>
>
>


-- 
Mariano
http://marianopeck.wordpress.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gforge.inria.fr/pipermail/pharo-project/attachments/20110509/0baeb60f/attachment.htm>


More information about the Pharo-project mailing list