[Pharo-project] bug in Nautilus/RPackage?

Cyrille Delaunay cy.delaunay at gmail.com
Fri May 20 10:19:03 CEST 2011


I don't know how to reproduce the situation in the screenshot, but I have a
small idea of what the problem is:
Your package Spy is composed of several subcategories. All the classes are
defined in the subcategories but none is defined in the one called 'Spy'.
In Rpackage, the classes are put inside the RPackage matching the category
in which the class is defined

2011/5/19 Alexandre Bergel <alexandre.bergel at me.com>

> Thanks for making it happen :-)
>
> Alexandre
>
>
> On 19 May 2011, at 15:39, Stéphane Ducasse wrote:
>
> > thanks for reporting it.
> >
> > do you have a reproducable way of arriving to this state?
> >
> >> Hi !
> >>
> >> I think I bumped into a bug when using Nautilus. I am not sure whether
> this is due to RPackage or not.
> >>
> >> I loaded Spy, and apparently there is no class in the package within
> Nautilus.
> >>
> >> Cheers,
> >> Alexandre
> >> --
> >> _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:
> >> Alexandre Bergel  http://www.bergel.eu
> >> ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
> >>
> >>
> >>
> >>
> >> <Screen shot 2011-05-19 at 11.21.23.png>
> >
> >
>
> --
> _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:
> Alexandre Bergel  http://www.bergel.eu
> ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
>
>
>
>
>
>
>
-------------- section suivante --------------
Une pi?ce jointe HTML a ?t? nettoy?e...
URL: <http://lists.gforge.inria.fr/pipermail/pharo-project/attachments/20110520/71061753/attachment.htm>


More information about the Pharo-project mailing list