[Pharo-project] loading code from command line inovcation

Hilaire Fernandes hilaire.fernandes at gmail.com
Mon May 30 21:12:39 CEST 2011


Some more tests:

1. this crash the image:
squeak PharoCore-1.3.image `pwd`/cacaboudin

cacaboudin does not exist

2. this crash the image:
squeak PharoCore-1.3.image `pwd`/empty.st

where empty.st is empty

3. this work:

squeak PharoCore-1.3.image `pwd`/test.st

where test.st only contains: Transcript show: 'hello'







Le 28/05/2011 22:53, Hilaire Fernandes a écrit :
> Still does not work
> 
> Hilaire
> 
> Le 28/05/2011 21:02, Guillermo Polito a écrit :
>> It seems code loader is not sending #startRetrieval to the UrlDownload
>> Request, and the Semaphore waits forever.
>>
>> I've put a changeset with what I think is a fix in the tracker :).
>>
>> On Sat, May 28, 2011 at 2:27 PM, Hilaire Fernandes
>> <hilaire.fernandes at gmail.com
>> <mailto:hilaire.fernandes at gmail.com>> wrote:
>>
>>     And the debug is there.
>>     The halt does not crash the VM in normal condition. (ie Alt-[.] is ok)
>>
>>     Hilaire
>>
>>
>>     Le 28/05/2011 19:07, Hilaire Fernandes a écrit :
>>     > And when there are no halt in commandLineHandlerAction:, the image is
>>     > frozen
>>     >
>>     > Le 28/05/2011 18:53, Hilaire Fernandes a écrit :
>>     >> With latest pahro core 1.3, I can't load script with command like
>>     >>
>>     >>
>>     >> squeak pharo "`pwd`\myScript.st"
>>     >>
>>     >> When I put a halt at the begining of commandLineHandlerAction:
>>     >> aCommandLine the VM crash
>>     >>
>>     >> VM is 4.0.3-2202
>>     >>
>>     >> Hilaire
>>     >>
>>     >>
>>     >
>>     >
>>
>>
>>     --
>>     Education 0.2 -- http://blog.ofset.org/hilaire
>>
>>
> 
> 


-- 
Education 0.2 -- http://blog.ofset.org/hilaire




More information about the Pharo-project mailing list