[Pharo-project] Cog+linux: external module not found

Mariano Martinez Peck marianopeck at gmail.com
Sat Jan 7 11:20:32 CET 2012


BTW, Eliot, is there a way so that FFI throws something different from
"Module not found" when the module is there but not 32 bits? like "Module
found but it is not 32 bits" ?
cheers

On Sat, Jan 7, 2012 at 10:04 AM, Nick Ager <nick.ager at gmail.com> wrote:

> Hi Bill,
>
> Have you tried strace to determine what library it's failing to load?
>
> Nick
>
>
> On 7 January 2012 03:26, Schwab,Wilhelm K <bschwab at anest.ufl.edu> wrote:
>
>>  Eliot,
>>
>> There is no /lib32 or /usr/lib32.  As a double check,
>>
>>     locate lib32
>>
>> returns nothing.  I put the library in /usr/lib, which is what I have
>> done on two other Lucid systems.  ldconfig shows it registered there.
>>
>> What's next?
>>
>> Bill
>>
>>
>>
>>
>>   ------------------------------
>> *From:* pharo-project-bounces at lists.gforge.inria.fr [
>> pharo-project-bounces at lists.gforge.inria.fr] on behalf of Eliot Miranda [
>> eliot.miranda at gmail.com]
>> *Sent:* Friday, January 06, 2012 7:29 PM
>>
>> *To:* Pharo-project at lists.gforge.inria.fr
>> *Subject:* Re: [Pharo-project] Cog+linux: external module not found
>>
>>
>>
>> On Fri, Jan 6, 2012 at 4:18 PM, Schwab,Wilhelm K <bschwab at anest.ufl.edu>wrote:
>>
>>> Paul,
>>>
>>> The library is 32 bit - I build it from source because it ships with 64
>>> bit binaries.
>>>
>>
>>  Then try changing your LD_LIBRARY_PATH to
>> /lib32:/usr/lib32:$LD_LIBRARY_PATH and see if that helps (if you have
>> /lib32 & /usr/lib32 that is)
>>
>>
>>>
>>> Bill
>>>
>>>
>>> ________________________________________
>>> From: pharo-project-bounces at lists.gforge.inria.fr [
>>> pharo-project-bounces at lists.gforge.inria.fr] on behalf of Paul
>>> DeBruicker [pdebruic at gmail.com]
>>> Sent: Friday, January 06, 2012 6:59 PM
>>> To: pharo-project at lists.gforge.inria.fr
>>> Subject: Re: [Pharo-project] Cog+linux: external module not found
>>>
>>>   Schwab,Wilhelm K wrote
>>> >
>>> > Eliot,
>>> >
>>> > I'm getting the same error with your latest VM.  Any ideas?
>>> >
>>> > Bill
>>> >
>>> >
>>> >
>>>
>>> When I had trouble with this it was a 64bit vs 32bit library mismatch on
>>> a
>>> 64bit OS.
>>>
>>> Is it a 32 bit or 64 bit OS?  Is the library you're trying to reach
>>> 32bit?
>>> 64bit libs won't work with the 32bit CogVM, but are installed by default
>>> by
>>> the Ubuntu package manager on a 64bit Ubuntu.
>>>
>>> Ubuntu also moved some mandatory (from Cog's perspectvie) 32 bit libs
>>> from
>>> their ia32-libs package to the ia32-libs-multiarch recently but I don't
>>> know
>>> if that change affects Lucid.
>>>
>>> --
>>> View this message in context:
>>> http://forum.world.st/Cog-linux-external-module-not-found-tp4271136p4271354.html
>>> Sent from the Pharo Smalltalk mailing list archive at Nabble.com.
>>>
>>>
>>>
>>
>>
>>  --
>> best,
>> Eliot
>>
>>
>


-- 
Mariano
http://marianopeck.wordpress.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gforge.inria.fr/pipermail/pharo-project/attachments/20120107/2096b693/attachment.htm>


More information about the Pharo-project mailing list