[Pharo-project] latest build yields stack trace running #cleanUpForProduction

Yanni Chiu yanni at rogers.com
Wed Jan 18 08:09:13 CET 2012


On 17/01/12 11:14 PM, Yanni Chiu wrote:
> On 17/01/12 5:15 PM, Mariano Martinez Peck wrote:
>>
>> can you reproduce the problem with that ?
>
> Nope, the code worked in both the new and old images.

Here's how I've reproduced the problem. Happens about half the time out 
of a handful of times - using a new image (that was never saved).

1. Get a new Pharo1.4 download
2. Open browser on implementers of #cleanUp:
3. Find the HashedCollection class>>#cleanUp: method in the browser
4. Select "self compactAll" and doIt

I've gotten the attached stacktrace twice, and it worked without problem 
another two times - even executed the code:
     Smalltalk allClassesAndTraitsDo: [...]
to try to detect the problem, but when it worked, it worked.
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: stacktrace
URL: <http://lists.gforge.inria.fr/pipermail/pharo-project/attachments/20120118/4a37f58f/attachment.asc>


More information about the Pharo-project mailing list