[Pharo-project] Trying to build CogVM in MacOSX 10.7 Lion

Igor Stasenko siguctua at gmail.com
Sat Jan 28 23:45:30 CET 2012


On 28 January 2012 23:22, Mariano Martinez Peck <marianopeck at gmail.com>wrote:

>
>
> On Sat, Jan 28, 2012 at 10:37 PM, Igor Stasenko <siguctua at gmail.com>wrote:
>
>> On 28 January 2012 22:11, Mariano Martinez Peck <marianopeck at gmail.com>
>> wrote:
>> >
>> >
>> > On Sat, Jan 28, 2012 at 10:04 PM, Igor Stasenko <siguctua at gmail.com>
>> wrote:
>> >>
>> >> On 28 January 2012 22:03, Igor Stasenko <siguctua at gmail.com> wrote:
>> >> > On 28 January 2012 19:00, Esteban Lorenzano <estebanlm at gmail.com>
>> wrote:
>> >> >> hi,
>> >> >>
>> >> >> you need to install xcode, not just gcc from macports (you'll need
>> the
>> >> >> libraries). Also, notice that Mariano's blog was outdated (I know he
>> >> >> was
>> >> >> working to update it this days, but I don't know if it is ready
>> yet)...
>> >> >> you
>> >> >> better use ConfigurationOfCog version 3.9, not the one in the blog
>> :)
>> >> >>
>> >> >
>> >> > Again same thing.
>> >> > Mariano, can you please change that entry in your blog by mentioning
>> >> > that they should _not_
>> >> > use a strange combinations of latest + updated stuff?
>> >> >
>> >> i meant latest + outdated :)
>> >>
>> >
>> > I think my blog is pretty clear regarding which version to use of each
>> part.
>> > In such a post I do not tell people to try latest of nothing. Each part
>> has
>> > fixed versions in order to be reproducible.  If you want latest...then
>> fight
>> > again the world, but my post do not support that ;)
>> >
>> >
>> >>
>> >> > If you checking out from git, you should _always_ use the config
>> which
>> >> > is in LoadVMMaker.st
>> >> > because if you don't then you will have all those funny errors.
>> >> >
>> >
>> >
>> > Well, I document that in the second part of the post:
>> >
>> http://marianopeck.wordpress.com/2011/04/16/building-the-vm-second-part/
>> > where in that case I explain how to do it without the specific versions
>> I
>> > say in the previous part.
>> >
>> > So it is simple... part 1 you use the exact versions I tell you and it
>> > should work. Part 2 is for trying to start the process from scracth if I
>> > don't tell you which versions, that is, using all latest code.
>> >
>>
>> The problem is that people checking out latest sources from git,
>> and then trying to build VM with outdated VMMaker config:
>>
>> 1       Deprecation raiseWarning: false.
>> 2        Gofer new
>> 3        squeaksource:'MetacelloRepository';
>> 4        package:'ConfigurationOfVMMaker';
>> 5        load.
>> 6        ((Smalltalk at: #ConfigurationOfVMMaker) project version: '1.5')
>> load.
>>
>> you then should mention that if they want to build VM for that confing
>> they should do
>>
>>
> The post already includes that:
>
> "
> git clone git://gitorious.org/~marianopeck/cogvm/marianopecks-blessed.git
>
> For this post, I recommend to take the first option if you may be a
> beginner. I told you that I wanted my posts to be reproducible. With the
> previous commands, you will clone the latest version in the repository.
> Since I don’t know when you are going to do it (if there is someone), I
> would like that you load the specific version I know it works. What I am
> suggesting is doing a kind of “svn co http://xxxx -r 2202″. I checked how
> to do this in git, and it seems not to provide a clone of a specific
> version. Instead, you just clone (from the latest one) and then you
> checkout or revert to a previous one. Execute:
> 1cd blessed
> 2git checkout f3fe94c828f66cd0e7c37cfa3434e384ff65915e
> "
>


so, why people keep doing it wrong? :)

--
Best regards,
Igor Stasenko.




-- 
Mariano
http://marianopeck.wordpress.com




-- 
Best regards,
Igor Stasenko.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gforge.inria.fr/pipermail/pharo-project/attachments/20120128/118d65e5/attachment.htm>


More information about the Pharo-project mailing list