[Pharo-project] Problems loading underscore assignments

Mariano Martinez Peck marianopeck at gmail.com
Sun Jan 29 11:49:30 CET 2012


On Sun, Jan 29, 2012 at 5:31 AM, Sean P. DeNigris <sean at clipperadams.com>wrote:

> I tried both programmatically ("Scanner allowUnderscoreAsAssignment: true")
> and via the settings browser to allow underscore assignments, but I still
> got errors loading AtomMorph. e.g.
>

I don't know which image version you are using but in last sprint I fixed
this:
http://code.google.com/p/pharo/issues/detail?id=4636

Cheers


>
>    "Syntax Error"
>    randomPositionIn: aRectangle maxVelocity: maxVelocity
>        "Give this atom a random position and velocity."
>
>        | origin extent |
>        origin _ aRectangle origin.
>        extent _ ***Nothing more expected ->***(aRectangle extent - self
> bounds
> extent) rounded.
>        self position:
>                (origin x + extent x atRandom) @
>                (origin y + extent y atRandom).
>        velocity _
>                (maxVelocity - (2 * maxVelocity) atRandom) @
>                (maxVelocity - (2 * maxVelocity) atRandom).
>
>
> --
> View this message in context:
> http://forum.world.st/Problems-loading-underscore-assignments-tp4337617p4337617.html
> Sent from the Pharo Smalltalk mailing list archive at Nabble.com.
>
>


-- 
Mariano
http://marianopeck.wordpress.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gforge.inria.fr/pipermail/pharo-project/attachments/20120129/77fddc68/attachment.htm>


More information about the Pharo-project mailing list