[Simgrid-user] SURF: Using GTNetS and network action delays

Kurt Vanmechelen kurt.vanmechelen at ua.ac.be
Thu Jul 10 18:36:37 CEST 2008


Hi Pedro,

Thanks for your effort to look into this.

I apologize for my late feedback on the GTNetS compilation (I was ill 
last week).
However, I just tried the compilation using the code and patches in your 
contrib section (instead of using the source code from the GTNetS site).

The GTNetS libraries were built on a Intel Quad Core Q9550 64bit using 
gcc 4.3. Due to the fact that 4.3 has cleaned up some header 
dependencies (see http://gcc.gnu.org/gcc-4.3/porting_to.html; C++ 
section), I had to add includes for e.g. <cstring> and <cstdlib> in the 
following files :
application-aodv.cc
application-sn.cc
application-webserver.cc
args.cc
memreuse.cc
nixvector.cc
routing-nixvector.cc
timerbuckets.cc

Aside from this the library built just fine.

The SimGrid configure script correctly finds the GTNetS headers and 
libraries but the SimGrid build process seems to choke on a missing header :
java/jmsg.c:21:38: error: jmsg_application_handler.h: No such file or 
directory
java/jmsg.c: In function 'Java_simgrid_msg_Msg_deployApplication':

I could not find that header anywhere in the repository. Do you still 
have to add it ?

Cheers,

Kurt

Pedro Velho wrote:
>
>
> 2008/6/26 Pedro Velho <pedro.velho at gmail.com 
> <mailto:pedro.velho at gmail.com>>:
>
>
>
>     2008/6/24 Kurt Vanmechelen <kurt.vanmechelen at ua.ac.be
>     <mailto:kurt.vanmechelen at ua.ac.be>>:
>
>         Hi,
>
>         I completed the integration of SURF and our simulator and
>         after spending some
>         quality time with the SURF layer :), I have the following
>         questions :
>
>         1. I would like to try out the GTNetS network layer.
>         Unfortunately the library
>         (latest version on the site) does not build on my system
>         (AMD64 with g++
>         4.1.2). It complains on an overload of a function based on a
>         size_t argument
>         versus unsigned int argument. Now, the overload was
>         conditional on a
>         preprocessor macro so I tried to disable the overload.
>         The resulting build went fine for a while until this came along :
>         ipv4.cc: In static member function 'static int
>         IPV4::IPV4ExportCallback(char*,
>         char*, int, void*)':
>         ipv4.cc:1264: error: cast from 'void*' to 'int' loses precision 
>
>         Did you succeed in building GTNetS on a 64-bit system?
>
>
>
>     Sorry about the late answer but I was experiencing some problems
>     to get a working opteron machine. I did a new GTNETS AMD64
>     specific patch that modifies some compilling options, at first
>     glance gtnets compile just fine in a opteron machine, detailed
>     configuration bellow. But I didn't have the same errors as you
>     did. I recommend you also to obtain the last simgrid version from
>     svn there is the communication remaining feature related to GTNetS
>     that is now supported.
>
>     *model name      : AMD Opteron(tm) Processor 248
>     stepping        : 8
>     cpu MHz         : 2193.160
>     cache size      : 1024 KB
>
>     clflush size    : 64
>     cache_alignment : 64
>
>
>     gcc (GCC) 4.2.3 (Debian 4.2.3-3)
>
>     *Although, I have not tried to execute simgrid with gtnets in that
>     platform. I will probably do it  tomorrow, i will keep you in
>     touch. Anyway, if you have the time to test it yourself let me
>     know if it is working or not with some good feedback output as before.
>
>     Thanks in advance,
>     -- 
>     Pedro Velho 
>
>
>
> I tried just now it seems to work just fine.
>
> Cheers,
> Pedro
>
>
> -- 
> Pedro Velho 





More information about the Simgrid-user mailing list