[Simgrid-user] Simgrid and OSX Lion

ENDERLIN Christophe c.enderlin at me.com
Tue Jul 26 18:20:23 CEST 2011


Le 24 juil. 2011 à 22:24, Arnaud Legrand a écrit :

> Hi,

Hi, (sorry for the silence, I had to go to hospital for a few days ...)

> 
>  I'm not sure activating supernovae is a good idea on a new system. You
> should go for the simplest possible options.

I tried without supernovae and my code behave differently, but it still doesn't work. All I get is either a bus error or a seg fault, depending on using '--cfg=contexts/factory:thread' or not.

> 
> Le dimanche 24 juillet 2011 à 18:46 +0200, ENDERLIN Christophe a écrit :
>> /Developer/simgrid-3.6.1/src/simix/smx_context_sysv.c:108: warning:
>> ‘getcontext’ is deprecated (declared at /usr/include/ucontext.h:37)
> 
> This does not look good to me. Furthermore, there is a "-- Looking for
> ucontext.h - not found" in the configure phase, which is thus pretty
> weird given the previous warning.

Yes that's right. I found files named ucontext.h in two places: /usr/include and /usr/include/sys/
but though they have the same name, they're quite different. Do you want me to join them to a mail ?

> 
> Try to run your code with the following option:
> '--cfg=contexts/factory:thread'. It should turn off the use of ucontext,
> which may be broken on this system (although it should be detected
> during the configure phase).

As I said, it doesn't work. But I noticed two other weird (for me, at least !  ;-) ) things:
When I launch cmake, I can see this message: 'System processor: amd64' whereas my processor is an Intel Core I3.
And 'Ucontext can't be used with this version of gcc (must be greater than 4.5)'. As far as I remember, my gcc has the same version as Snow Leopard one.

Have you got some more ideas ?

Thanks for your help !

Best Regards,

Christophe


> 
> Best regards,
> 
>    Arnaud
> 
> -- 
> One man's constant is another man's variable.         
>   -- "Epigrams in Programming", by Alan J. Perlis of Yale University.
> 




More information about the Simgrid-user mailing list