[Simgrid-user] Simgrid and OSX Lion

ENDERLIN Christophe c.enderlin at me.com
Wed Jul 27 19:31:16 CEST 2011


Le 24 juil. 2011 à 22:24, Arnaud Legrand a écrit :

> Hi,

Hi,

My code still doesn't work on OSX Lion, but I noticed a few things that might be of some interest.

> 
>  I'm not sure activating supernovae is a good idea on a new system. You
> should go for the simplest possible options.
> 
> Le dimanche 24 juillet 2011 à 18:46 +0200, ENDERLIN Christophe a écrit :
>> /Developer/simgrid-3.6.1/src/simix/smx_context_sysv.c:108: warning:
>> ‘getcontext’ is deprecated (declared at /usr/include/ucontext.h:37)
> 
> This does not look good to me. Furthermore, there is a "-- Looking for
> ucontext.h - not found" in the configure phase, which is thus pretty
> weird given the previous warning.

I tried something. In /usr/include/ucontext.h, I defined _X_OPEN_SOURCE (I did it there because I couldn't find out how to tell cmake to do so). Now ucontext.h is found in the configure phase, but I still get the warning that its functions are deprecated. This is normal since this is what is written in ucontext.h. In fact, I'm not sure OSX is able to deal correctly with contexts.

But since it's also the case with OSX Snow Leopard, I don't think my problem comes from there.

I also noticed something else. For my application, I've generated a deployment file for 4000 hosts. On OSX, when I launch my application, it takes several minutes (and all my RAM - 4Gb) to deal with this file, then the rest works fine. When I try the same code on Linux (Ubuntu), I don't have those problems: it all starts and run quickly. (I must precise that my Linux is on a virtual machine on my Mac)

I also tried to compare the cmake/make logs on Snow Leopard and Lion, and I can't see much difference, except some messages:
'-- Warning: sem_init not executable'
'-- Ucontext can't be used with this version of gcc (must be greater than 4.5)' (I don't understand this one because on Linux, I don't have this version of gcc and I don't get this warning)
'-- Warning: MMAP is thought as non functional on this architecture (Darwin-11.0.0)'

Finally, I tried the git version, but I get this error during make: '/Developer/git/simgrid/teshsuite/simdag/platforms/Evaluate_get_route_time.c:39: error: ‘CLOCK_REALTIME’ undeclared'

Any help would then be greatly appreciated !  :-)

Best regards,

Christophe


More information about the Simgrid-user mailing list